59 Comments
  1. I cannot get the sequence to work for the wizard’s room. I have moved the arrows the way the fixed arrows are moving – counter clockwise…nothing

  2. Hi, I played through Pahelika, and it was a great game. I can’t believe just two people made this up!

    Anyway, I’m commenting here because I can’t find any appropriate “contact” page (sorry!). I run a blog with puzzle game reviews, and I would like to trackback to your blog. Any guide on how I can do that?

    Your help would be much appreciated! Here is my blog: http://reviewsekai.wordpress.com

    And please keep developing more such games, I’m sure they’d all be classics like Pahelika!

    1. Thank you for the review. We will definitely keep developing more games

  3. I just finished playing Pahelida: Secret Legends. Loved it. Will there be a sequel to it? Keep up the good work.

    1. Defenitely. We have tentatively titled it: Pahelika: Revelations

  4. I am in the library and cannot get the cupboard to open to get the fairy dust and the spell. I need help -have been on this for just about an hour. Everything as far as I am concerned has been put back in place but the door will not unlock. I am going crazy.

  5. OK, I really love this game, not too hard, no need for a strategy guide but it is great that you guys offer one for free, which is how I found your site, since I have been playing all day and can’t stop. I had no problems figuring out the puzzles in each level till I got past the snowman – really not playing fair with your players to reorder the numbers from 253 to 235, that drove me insane!

    Now I am at the island and had to come here to comment and cry and whine because I have already spent over an hour twiddling with the levers to power the machine, and finally broke down to grab the strategy guide, and all it says to do is trial and error!!!

    The puzzles have been fair and logical till now but this is too much. Please tell me how to get past this, I can’t even remember if the levers are supposed to be straight or tilted back to start testing any sequence and there is seemingly no restart of the puzzle. I want to finish this game, I was loving it till now!!

    For the next great game, provided I can ever finish this one – I think you should include a clickable description of the objects that get picked up for inventory, just so the player knows what he or she is playing with.

    1. @gmon:
      Set the levers to the following positions:
      1: Back
      2: Back
      3: Forward
      4: Forward
      5: Back

      @Kay: Did you miss the torch that is on the chair, or did you forget to close the open cupboards?

  6. I’m stuff in the Fairy Gardens. I can’t find the secret scroll to continue making the potion.

    1. The scroll is in the hollow of the tree (The tree near the big stone).

  7. Awesome! thanks so much, I was able to finish the game and can’t wait to play the next one, charge double for it since I will gladly pay it!!!

  8. I’m stuff I can’t figure out how to get the bow-thing and wood things together

  9. stuck in the first ice room, can’t get the hammer to break the ice shards, keeps saying the hammer is out of reach. any ideas

  10. stuck in the first ice room, got the hammer but cant get it to break the ice shards help please

  11. I have tried repeatedly to put the symbols that are on the wall of the ice room in the machine in the right order. I have reset about 100 times. What is the symbol that is 3rd from the end? Is that a rectangle? What am I doing wrong? Please help. Elle

    1. @Elle: The symbols are: Triangle, Plus Sign, Square, Eight, Pentagon, Triangle

  12. Pick up the blocks of ice and stack them to the right and then you can reach.

  13. Love it, Love it and Love it some more. Cant wait for episode 2. Thanks guys and fair play to you – 2000 man hours!!!! Hope it makes you a small fortune or it least enough to keep you going for another 2000 man hours:-)

  14. I am stuck in the ice room. Every time I try to hit the tuning fork with the hammer, the hammer drops back into inventory. Can someone help me with this?

    1. @Donna:
      Place the tuning fork on the iron pedestal inside the ice pillar, then hit it with the hammer.

  15. oh i love pahelika: secret legends. can wait ’til the sequel coming. how long will it take ? i’m so nervous. i wish you don’t just make the sequel, make the 3rd, 4th… i am willing to pay it all.

  16. I am stuck on the island. It says to take the two pieces of wood and the bow thing to make the fire thing. I have no idea what wood things they are talking about. I have collected all the items available. Care to give me a hint as to what they look like?

  17. I love the game Pahelika but i feel somewhat dumb because I have to use the stragety guide on almost every level. Are there clues I should look for?

    1. @Aurelia:
      Maybe you are new to puzzle games. It will get easier as you play more games & get experienced.
      Click on everything and read the text. That will give you clues.

  18. Have just finished Pahelika – and the only complaint is that it isn’t long enough – more please soon.

  19. Now I can’t ring the bells in the correct order. Please help. Love the game but it needs to be longer

    1. @Aurelia:
      Pay attention to the sound of the bells. When you hear a bell toll, that means you have the right sequence. When you hear the other sound, that means that you rang the wrong bell.

  20. how don i know when the prssure is correct can’t get teleporter activated helpppppppp!

    1. quest4me2u@:
      Just keep the needle in the green zone for a little while.

  21. I am stuck on the shores of yanta nagori I have the fire starter but how do I MAKE THE FIRE. I am loving this game as much as angkor maybe a little more.

    1. @Mary:
      Use the fire starter on the wooden plank to set it on fire. Then use the wooden plank on the coal.

  22. can not pass the compass to enter the room

  23. stuck on the jigsaw puzzle in the ice room, any help would be appreciated

    1. @Lynn:
      I can only give you a general hint. Try to fit the corner and edge pieces first, as it is easier to find the correct place for them.

      You know a piece is an edge piece one one of its edges is straight. Then you can try to fit it at the edges of the puzzle board.

      @Harriet:
      Only the very experienced people finish the game without getting stuck somewhere, so its okay!

  24. I’m in the ice room, I have the hammer, I have not found the pot that is supposed to be there and the door out is stuck. HELP!!!

  25. I figured it out thanks, I love this game!! A “new to games” person. Obviously, right?

  26. I guess I used the wrong wording, I am stuck at the letter board so that I can activate the mechanism. By the way, love the game!!!

  27. finally got it and finished the game, great job, keep it up

  28. Well if you just click all over the place you find the other tool. I did this and made it through the rest of the game. What an adventure! Thank you for designing a wonderful game. When is the next one?

    Thanks again,

    Harriett

  29. Hi, I am stuck in the fairy garden – outside. I am trying to go fishing . I have the magnet on the line and take it to the stream but nothing ‘sticks’ . I am stuck here until someone can help me. Thanks in advance.
    Becky

    1. @Becky: You need to click on the stream.
      @Harriett: Great to know you finished the game. The next one in the series, ‘Pahelika: Revelations; will be released around march next year.

  30. In the fairy garden the oak branch won’t go into the pot and I can’t carry anymore items. No way to restart the level and no way to put things down I don’t need or am done with like the fishing pole.

    1. @Loki:
      Put the crystals into the slot to the right of the gate. You need to put the crystals in the right order. Start with the topmost slot. Also, you need to put crystal exactly into its own slot. Example, take the orange crystal and put it into orange slot, by clicking on the orange slot. If you try to put orange crystal into red slot, it will be repelled.

  31. i’m stuck in the keyword pad in the iceroom with the 2 centry guard look at me and maybe laugh of me because i’m not able to find the word to open the door…someone could help me please???

    1. @marilyne:
      The code is on the big rectangular ice slab. It is ‘ooooo’.

      @Robin: This post:
      http://ironcode.com/wordpress/?p=34

      @Mary:
      Select each machine by turning the knob. Then turn on the Selected machine by turning the crank. This way you can select all the machines and activate them one by one.

  32. I have the bow thing and one strange wooden piece shaped like an upside down J,but cannot find the other wooden piece. You advised Ruby to look at the end of the post. What post?

    Love the game, Robin

  33. am stuck in teleporter room got 2 machines working but can’t get 3rd one to power up bottom turns but that is all I put it on #1 and did turn the crank but the bottom of #3 just turns

  34. I thought this game was just great! Made me think and the jigsaw puzzles weren’t too easy. Could have had more mini-games, though.

  35. I am stuck in the fairy hut….don’t understand what to do with any of the items I have.

  36. Figured it out but thanks anyway. Will probably need you yet!!

  37. what a excellent game pahelika is. thoroughly enjoyed it.
    well done for all people who thought of it and all the man hours put into it. hope to see a follow up in future.
    loved all the puzzles .

  38. RE Pahelika: I do not know if anyone else is having this problem, but am I getting an Access Violation 0x0041 C60A tried to access from 0x0000000 at the very begining of the 2nd area of the game.
    I have tried it in Windows 7 and on XP. Version downloaded from Oberion.

    1. @Ray: Difficult to say what the problem could be. Perhaps the savegame has gotten corrupted somehow. Try deleting your save games. Or start a new game. In the main menu click on the tilted painting to create a new profile. Then you can start a new game.

  39. I am stuck in the Fairy Garden, can’t find the rope for the bucket – HELP!

  40. how do i apply for A job at ironcode studios..??

  41. Stuck in ice room can’t figure out what the word is for the puzzle. Please help.

  42. stuck in the ice room grand hall. what is the keypad word? please help

Comments are closed.